Switching Magento 1.x to PHP 7.2 service

This service is intended to help when your host decided to drop old PHP 5.4 or PHP 5.6, and Magento 1.x still depends on it. Likely, there is official PHP 7.2 compatibility patch for Magento 1.9.x and we apply it on a staging store first.
The process is as follows:

  • you submit the request form and initiate the payment
  • we connect to your servers and verify the information and Magento state
  • if you selected “staging verification” option, we clone your store to our staging server with PHP 7.2
  • we install PHP 7.2 compatibility patch (it is backward compatible with older PHP versions)
  • we check and fix known issues, related to PHP 7.2 compatibility
  • you verify updated store (on staging server first, if corresponding option was selected)
  • we deploy changes from staging to production (if corresponding option was selected)